Типовые проблемы Manjaro Linux для новичков (обновляемая статья) / Учебники (How-To & F.A.Q) / …



Учебники (How-To & F.A.Q)

   55788

Типовые проблемы Manjaro Linux для новичков (обновляемая статья)

    Уважаемые новички Manjaro Linux, если вы решили впервые начать использование Manjaro Linux и не знаете с чего начать, а тратить своё архидрагоценное время на «бесполезное» чтение Wiki и форумов, нет ни времени ни желания, то эта статья для вас.

    Для начала, попробуем ответить на наиболее частые общие вопросы о системе.

    1. Mаnjaro — это Arch?
    Манжаро основан на Арч. Они весьма похожи друг на друга.

    2. Mаnjaro — это Arch + графическая инсталляция?
    Верно, Manjaro Linux имеет довольно удобный графический установщик(на данном этапе их два Thus и Calamares), но Manjaro уже не Archlinux, так как имеет свои ядра, свои репозитории, свои отличные от Archlinux пакеты в репозиториях и свои утилиты конфигурации, которые изрядно облегчают установку ядер и драйверов.

    В Арчлинуксе есть стабильные репозитории и testing репозитории, во вторых как понятно из названия, пакеты тестируются и если багов нет, то переносятся в стабильный. Из стабильной ветки основное число пакетов берется и переносится в Manjaro unstable ветку репозиториев, в которой пакеты тестируются и в случае отсутствия багов переносятся в testing репозитории Манжаро, откуда после недолгой обкатки переносятся в stable версию Manjaro репозиториев. Тоесть стабильные пакеты в арче, считаются еще нестабильными пакетами в манжаро и подлежат дополнительной обкатке и проверке.

    3. Можно использовать репозитории Арча?
    Официальные репозитории- нет. Но репозитормй AUR- можно.

    4. Зачем использовать Mаnjaro, когда есть Arch?
    Не видите для чего вам Manjaro Linux, используйте Arch.

    Какой вариант Mаnjaro использовать?

    Новичкам в линукс рекомендуется стабильная ветка Манжаро, вариант c XFCE или KDE. Этим вариантам разработчики Mаnjaro уделяют особое внимание. XFCE проще, KDE богаче, оба красивые. Естественно, качайте последний релиз. Ссылка на скачку здесь или в главном меню сайта.

    Чем писать образ на флешку?

    Итак начнём с самого начала, предположим, что вы скачали образ Manjaro Linux и не знаете чем записать образ на флешку, априори считаю, что вы находитесь в Windows, посему рекомендую пользоваться rufus, ultra iso или win32 image writer.

    Если вы используете Linux то воспользуйтесь — isousb, imagewriter, multisystem, dd.

    С чего начать установку?

    Вот вы записали образ, загрузились с флешки, вне зависимости от вашего выбора установщика Thus или Calamares(не думаю, что те кто выбрал CLI установщик нуждаются в подсказках) рекомендую выбирать в первом случае язык системы русский, а вот раскладку выбирать по умолчанию USA english default, таким образом будет исключена проблема с вводом пароля(есть такой старый линуксовый баг, встречаемый во многих linux установщиках).

    Как разбить диск?

    На этапе разметки диска, если у вас EFI то обязательно создайте раздел размером, примерно 100 мегабайт(если у вас будет одна система, если будет ещё винда в дуал буте, то сделайте примерно 200 метров на всякий случай) с файловой системой fat32, размечаем его в /boot/EFI, так же обязателен раздел / размером от 15 до 50 Гигабайт на ваше усмотрение и аппетиты. Необходимость лично для вас раздела /home можете поискать «в этих ваших интернетах», так глубоко углубляться в это углубление я не буду.

    Если у вас BIOS, то обязателен лишь раздел / (он же root, он же корень), так же от 15 до 50 Гигабайт на ваше усмотрение и аппетиты, с необходимостью лично вам других разделов, так же разберитесь самостоятельно.

    Рассмотрим частые проблемы

    И вот пред ваши ясны очи предстала впервые загруженная ОС Manjaro Linux, радости вашей и восторга а у некоторых уже на этом этапе трещат пуканы нет предела. И первое, что делает любой уважающий себя пользователь Manjaro это конечно же открывает эмулятор терминала и выполняет в нём команду на сортировку зеркал серверов по их скорости.

    sudo pacman-mirrors -g

    После чего выполняем полный апдейт системы:

    sudo pacman -Syyuu

    На данном этапе нередко случается ошибка вида:

    :: Synchronizing package databases…
    error: failed to update core (unable to lock database)
    error: failed to update extra (unable to lock database)
    error: failed to update community (unable to lock database)
    error: failed to update multilib (unable to lock database)
    error: failed to synchronize any databases
    error: failed to init transaction (unable to lock database)
    error: could not lock database: File exists
    if you’re sure a package manager is not already
    running, you can remove /var/lib/pacman/db.lck

    Ошибка появляется не потому что «Манжаро УГ», а из-за того, что пакетный менеджер pacman в данный момент работает или завершился некорректно, и потому в системе уже существует файл блокировки /var/lib/pacman/db.lck и как вам написано в сообщении, для устранения проблемы удалите этот самый файл:

    sudo rm /var/lib/pacman/db.lck

    После удаления репозитории синхронизируются и есть вероятность того, что с момента выхода скачанной вами версии некоторые ключи, которыми подписаны пакеты уже устарели и вы столкнетесь с ошибкой вида:

    ошибка: libpulse: signature from «Rob McCathie <korrode@gmail.com>» is unknown trust
    :: Файл /var/cache/pacman/pkg/libpulse-5.0-1.1-x86_64.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись)).
    Хотите его удалить? [Y/n] y
    ошибка: jasper: signature from «Rob McCathie <korrode@gmail.com>» is unknown trust
    :: Файл /var/cache/pacman/pkg/jasper-1.900.1-12.10-x86_64.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись)).
    Хотите его удалить? [Y/n] y
    ошибка: lib32-libpulse: signature from «Rob McCathie <korrode@gmail.com>» is unknown trust
    :: Файл /var/cache/pacman/pkg/lib32-libpulse-5.0-1.1-x86_64.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись)).
    Хотите его удалить? [Y/n] y
    ошибка: pulseaudio: signature from «Rob McCathie <korrode@gmail.com>» is unknown trust
    :: Файл /var/cache/pacman/pkg/pulseaudio-5.0-1.1-x86_64.pkg.tar.xz поврежден (неверный или поврежденный пакет(PGP-подпись))

    Для решения этой проблемы достаточно установить пару пакетов свежих ключей:

    sudo pacman-key --init

    sudo pacman-key --populate archlinux manjaro

    Убираем прерывания(tearing) в KDE
    Если есть правим если нет создаем и правим файл

    sudo nano /etc/profile.d/kwin.sh

    добавляем в него две строчки

    export __GL_SYNC_TO_VBLANK=1
    export __GL_YIELD=USLEEP

    Спасибо:

    за исправления и замечания уважаемому Doaxan
    за дополнения и поправки к статье уважаемому dimonmmk

    Написал о наиболее часто задаваемых вопросах. Статья будет дополняться. С дополнениями и пожеланиями прошу в комментарии или ЛС. Всем Добра.



    • manjarqo

    • 16 апреля 2016, 00:32
    • 8

    • +19

    ?


    Хочешь оформить кредит, кредитную или дебетовую карту? Спроси меня как!

    https://manjaro.ru/blog/how-to/tipovye-problemy-manjaro-linux-dlja-novichkov-obnovljaemaja-statja.html

    Губарь Маргарита Александровна